Can't build swift 5.1 toolchain

Hi all, I'm trying to build a swift toolchain - swift-5.1.3-RELEASE, but, unfortunately, it's failing with the following error:

./swift/utils/update-checkout --scheme swift-5.1-branch --reset-to-remote --clone
...

./swift/utils/build-toolchain dev.swift

...

CMake Error in cmake/modules/CMakeLists.txt:
      export called with target "swiftSwiftLang-macosx-x86_64" which requires
      target "sourcekitd" that is not in any export set.

Same error happens with swift-5.1.3-RELEASE tag. Not building sourcekitd isn't an option, the build fails later on with different errors.

Everything works fine on master branch, anything I'm missing here?

I did not find root cause, but I think you can build it by using cmake 3.15.5

@aleksgapp I wouldn't be surprised if this is: https://github.com/apple/swift/pull/29282#issuecomment-575791522.

That being said, this is swift-5.1.3 and I don't know if we are going to make another tag of this.

@mishal_shah your thoughts?

We are planning on releasing Swift 5.1.4 soon, Development open for Swift 5.1.4 for Linux

did you solved this problem?

Afair, cherry-picking this https://github.com/apple/swift/pull/29282 fixed it for me

1 Like

thanks ,it woked :laughing:

I also have this problem. How can I solve it?

@WXKernel - How to cherry pick?

  1. Goto https://github.com/apple/swift/pull/29282

  2. Then to the "commit" -tab ( https://github.com/apple/swift/pull/29282/commits )

  3. Click to copy the git-commit-number-hash

  4. In the cloned swift repro, execute:
    git cherry-pick 259afb2a567f7111fc692baa986f77d786999575

it works.

Terms of Service

Privacy Policy

Cookie Policy