Xcode 10.2 beta stopped working

swift5
xcode

(Daryle Walker) #1

I tried out the Xcode 10.2 beta a few days ago to check out Swift 5. I used it on my macOS 10.14.2 boot drive and my 10.14.4 beta SSD, and it seemed fine both times. A few days ago, Xcode stopped working; the Swift CLI tool I was working on, and a new project, crash before they even get to main:

dyld: Library not loaded: /usr/lib/swift/libswiftSwiftOnoneSupport.dylib
  Referenced from: /Users/daryle/Library/Developer/Xcode/DerivedData/CLITest-dnzykavxvqkbaucmyxrrofnvancn/Build/Products/Debug/CLITest
  Reason: image not found

Last time, my laptop was in the middle of a 10.14.3 install, but it still persists even though the install is finished.

I saw a suggested thread, and "SWIFT_FORCE_STATIC_LINK_STDLIB=YES" didn't seem to help (or I put it in wrong).


(Jordan Rose) #2

That's definitely the appropriate release note for what you're seeing. Did you add SWIFT_FORCE_STATIC_LINK_STDLIB to the right target, in all configurations? That's usually what I get wrong.


(Daryle Walker) #3

Never tried; by the time I looked at the problem some more, Xcode 10.2 beta 2 came out, which has seemed to fix the immediate problem.