What's happening that I receive always no such module 'module-name'

What's happening that I receive always no such modules?

I run pod install before to open my-Project.xcworkspace as Xcode 8.3 or other Xcode version.

If I comment this line, it generate an error in others imports as well.

Bellow is my pod env:

~$ pod env

Stack

   CocoaPods : 1.5.3
        Ruby : ruby 2.3.7p456 (2018-03-28 revision 63024) [universal.x86_64-darwin17]
    RubyGems : 2.5.2.3
        Host : Mac OS X 10.13.6 (17G65)
       Xcode : 9.4.1 (9F2000)
         Git : git version 2.18.0
Ruby lib dir : /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib
Repositories : master - https://github.com/CocoaPods/Specs.git @ f5b3095c0e0c194f1d0ce28a808267cddb5f1a38

Installation Source

Executable Path: /usr/local/bin/pod

Plugins

cocoapods-clean       : 0.0.1
cocoapods-deintegrate : 1.0.2
cocoapods-plugins     : 1.0.0
cocoapods-search      : 1.0.0
cocoapods-stats       : 1.0.0
cocoapods-trunk       : 1.3.0
cocoapods-try         : 1.1.0

Podfile

# Uncomment this line to define a global platform for your project
platform :ios, '9.3'
# Uncomment this line if you're using Swift
use_frameworks!

target 'my-Project' do

	pod 'Alamofire', '~> 4.0'
	pod 'MBProgressHUD'
	pod 'PromiseKit', '~> 4.0'
	pod 'MBAutoGrowingTextView', '~> 0.1.0'
	pod 'PusherSwift', '~> 3.0'
	pod 'PopupDialog', '0.5.4'
	pod 'SwiftMessages'
	pod 'Bugsnag'
	pod 'AutoCompleteTextField'

	pod 'Fabric'
	pod 'Crashlytics'

	target 'my-ProjectTests' do
		inherit! :search_paths
	end
end

post_install do |installer|
	installer.pods_project.targets.each do |target|
		target.build_configurations.each do |config|
			config.build_settings['SWIFT_VERSION'] = '3.0'
		end
	end
end

I found this reference:

but for me...

I have 3 targets, where 1 is for tests.

The TARGET 1:

The Framework Search Paths property contains a different values using $PROJECT_DIR like the screenshot below:

The TARGET 2 (for Dev):

image

If I try to compile, the simulator doesn't exists, and I cannot add no one because the screen of Create a new Simulator don't confirm.

The build directory doesn't exists. So now?

I abandoned this way to try to solve it.

My second way to solve that: