Various included packages suddenly "Failed to parse the manifest file"

Hello there!

I am a dev member, and in my team we had a problem with our included packages. Everything worked fine the other day, and then trying to build the project or to reset spm cache always fails with almost all packages saying Failed to parse the manifest file. Even creating a new user and using a clean clone doesn't help, as soon as the error appeared there is no fixing. Today, another team member came suddenly up with the same problem. They are completely blocked, and I am starting to panic a little. We will be trying to further investigate, but please, if anyone has had a similar problem/any advice, we would greatly appreciate it.
I am the last one where everything seems to work.

Xcode 13.1, macOS 11.6 and 12.0.1
See attached screenshot for the error.

Try deleting the derived data folder: ~/Library/Developer/Xcode/DerivedData.

Thank you very much, we did delete the DerivedData folder, didnt help.

I have had a similar experience in the past, thats why I tried to disable TrendMicro Security Agent.
And - it turns out Xcode worked like a charm after that. I need to confirm that with my colleagues first, but it looks like the Antivirus is to blame ... wow.

Terms of Service

Privacy Policy

Cookie Policy