Vapor Installation Issues (First time using Vapor)


(Jake Tiritilli) #1

Hello,

I am new to using Swift and am interested in learning Vapor. I recently installed Vapor with Homebrew, but when I use any Vapor command from the terminal, I receive this error:

dyld: Library not loaded: /Users/tanner0101/dev/vapor/toolbox/.build/x86_64-apple-macosx10.10/release/libSwiftPM.dylib
  Referenced from: /usr/local/bin/vapor
  Reason: image not found
Abort trap: 6

I am using the latest stable versions of Xcode and Swift, and tried reinstalling with brew install -force vapor/tap/vapor, but I still keep getting the same error. Any idea what could be causing this? Thanks for the help!


#2

Toolbox was updated earlier today and it looks like something may have gone wrong with the home brew upload.


(Jake Tiritilli) #3

Just updated the package and it's now working correctly, thanks.


(Jainam Shah ) #4

Vapor Installatio Issue

I am trying to install Vapor on my MacBook Pro running macOS Mojave 10.14.1 through homebrew. I keep on getting this error. Can anyone tell me what's wrong and how to fix it ?


#5

Have you already tried brew update?


(Jainam Shah ) #6

Yes I did brew update as well. Still getting the same error


#7

Give this a try.

This is an issue with homebrew and not Vapor btw.


(Jainam Shah ) #8

Hey thanks for the reply. The installation worked but now I get an error saying

RuntimeError: /usr/local/opt/pkg-config not present or broken
Please reinstall pkg-config. Sorry : (


(Jainam Shah ) #9

When I try to link the pkg-config using 'brew link pig-config'

I get an error Error: Could not symlink . /usr/local/opt is not writable.


#10