Swift 5.6 released!

Swift 5.6 is now officially released!

Swift 5.6 includes a number of enhancements to the type system, improved interaction with pointers, and adds the ability to run new plugin commands using the package manager.

Thank you to the entire Swift community for helping bring this release together! :confetti_ball:

61 Likes

@tkremenek This URL is incorrect. The blog post is found @ Swift.org - Swift 5.6 Released! :slight_smile:

3 Likes

Thanks... I wonder if that was some Discourse quirk. Plugging in the URL I had worked by itself.

SE 302 Sendable was punted to 5.7 by the way… might want to take that out of the 5.6 features document, unless I’m mistaken.

2 Likes

Exciting! Curious what the status of SE 309 is? Sounds like that didn't make it to 5.6?

That's right, SE-0309 is not implemented in Swift 5.6. The proposal authors are still actively working on the implementation.

1 Like

Thanks for noting this. This got picked up by a script before SE-0302's status was updated in the proposal Markdown file. An update to the blog post will go out shortly to remove it.

Congratulations,

just curious, what is the process of pushing official swift images to docker hub?

I just checked and if I am not missing anything the 5.6 docker images are not yet live (Docker Hub)?

But the Dockerfile for 5.6 seems to be ready.

It's been only a day since official release, I know... :slight_smile:

thanks, just wondering if there is anything we are waiting for...
Martin

The official Docker images need to go through Docker's CI. You can see the PR at [Swift] Add Swift 5.6 Release to offical image by shahmishal · Pull Request #12038 · docker-library/official-images · GitHub

It looks like that's close to being ready so once merged the images will be built and pushed so hopefully not long now!

3 Likes

Excellent, thanks for the clarification :slight_smile:
Martin

Swift-DocC Updates :partying_face:

2 Likes

Just so you know, the description of 0302 is still there in the body of the text…

Thanks for noting. That has been removed.

Just some (annoying) additional info: Swift 5.6 needs Xcode 13.3. For Xcode 13.3 you need macOS Monterey. As my still perfectly running MacBook Pro (Late 2013) doesn't support Monterey (only Apple knows why), it's shocking for me, that there is now this cut for me (and probably for other developers too).

3 Likes

I think 9 years use out of any electronic equipment with decent development trajectory is stunningly good.

If you just need Swift 5.6, you can run a Linux VM and run it there. Unfortunately there's no way to ship apps without Monterey.

1 Like

As I bought this MBP I never thought, that I would use this so long. But as I bought one with i7, 32GB RAM and second graphic card, there is still absolutely no need to change the hardware. Apple tells everywhere, that it is a green company, they even write on their homepage "In the fight against climate change, every voice matters." But they force me to buy a new laptop and throw my old one away, which is even perfect for developing (SwiftUI and all the stuff is working perfectly!).

@Jon_Shier : I am developing a SwiftUI app, so using Linux in a VM is not an option. And I don't ship my app in the App Store (it's not an iOS app).

4 Likes

I haven't tried it but I wonder if you could virtualize a never version of macOS. It's not the greatest in a VM, but it could work.

Have a look at this. I've not used this project in particular, but have been very happy with OpenCore for other uses.

Thanks, I know this. But although this patcher is open source, I am not feeling well using something, that directly modifies the system. That seems not very secure for me.

But: I had a look and my MacBook Pro Late 2013 is fully supported. Actually all the models from 2012 are fully supported. This says everything about the statement of Apple according to save the environment....

I don't want to vent my frustration here, my post was
a) just an info, that is not mentioned in the release infos (there you can only find, that you need Xcode 13.3) and
b) it's a question to the Swift team, why it is not possible to support the newest Swift versions in older Xcode versions.