SPM Xcode project generation, test targets don't see modules (Xcode 9.3, Swift 4.1)

This was all working at Swift 4.0.3 and XCode 9.2, but now when I generate the Xcode project (from clean clone) and try to run the test target the import <> fails. Looking at the configuration from the test target it appears to be linking the correct binaries to make the module available so I'm somewhat at a loss to what the problem is.

If someone had the time to try it themselves they could clone: GitHub - SwiftStudies/OysterKit: OysterKit is a framework that provides a native Swift scanning, lexical analysis, and parsing capabilities. In addition it provides a language that can be used to rapidly define the rules used by OysterKit called STLR and checkout the enhancements/ut-coverage branch, generate the Xcode project and try and test either the OysterKit or STLR modules.

Thanks in advance for any clues!

The issue turned out to be a dumb mistake on my part. Missed a dependent target. Doh.

I have been going through the OysterKit Bork tutorial myself and have ran into two immediate problems:

  1. 'Testing the Grammar' section runs smoothly though the terminal. Although as soon as I generate an Xcode project, and where I am welcoming the player, I am unable to run the program to see these results. Do I run the program in the terminal or in Xcode and expect output in the console?

  2. I have been getting this error each time I try making the project. Have you encountered anything like it? Error:"Value of type 'HomogenousTree' has no member 'tokens'.

1 Like

That looks like my mistake not fixing following a refactoring. I'll take a look this afternoon and push an update but my guess is tokens is now children.

I've fixed the tutorial code in the repository: Bork Tutorial

As well as fixed issues with the Bork example repository itself.

Apologies that I had let this fall behind.

1 Like

Off topic, but strippingNewline defaults to true, so there's no reason to pass that argument explicitly.

1 Like

Good tip (less code is better code)... I'll update later.....


1 Like

I'm back. Something's gone wrong with the parser or something else. It won't see the Grail.swift file and the parser() within it. (Grail is the name of my Bork game). When I run swift mail.swift inside the /Grail/Sources/Grail directory I get this.

It cannot see the Grail.swift file and the parse(source: ) method inside it. What am I doing wrong?

Many thanks!

Try regenerating the xcode project. Grail.swift may not be included in the target