[Revision] SE-0034 - Disambiguating Line Control Statements from Debugging Identifiers

#sourceLocation(file: "foo", line: 42) // Set logical position.
#sourceLocation() // Reset logical position.

I fully support renaming of the first directive, but have a tiny concern
about the second one.
Does sourceLocation name reflect its purpose? Maybe resetSourceLocation or
something like that?

Perhaps
    #sourceLocation(reset)

which provides space for other potential future constructs
    #sourceLocation(push)
    #sourceLocation(file:"foo", line: 42)
    …
    #sourceLocation(pop)

···

On Mar 12, 2016, at 2:17 AM, Антон Жилин via swift-evolution <swift-evolution@swift.org> wrote:

#sourceLocation(file: "foo", line: 42) // Set logical position.
#sourceLocation() // Reset logical position.

I fully support renaming of the first directive, but have a tiny concern about the second one.
Does sourceLocation name reflect its purpose? Maybe resetSourceLocation or something like that?

--
Greg Parker gparker@apple.com <mailto:gparker@apple.com> Runtime Wrangler