I like the idea of changing some reserved words. Aren't 'private', 'friend,
'public', 'internal', etc just metaphors that were built on top of object
encapsulation (another metaphor)? I think we're starting to see the limits
of stretching metaphoric syntax.
Why can't we just start naming access modifiers literally: a location in
the code that they apply to. Examples such as "scope" or
"insidethecurlybraces" or "file" or "module" or "submodule" or "codebase".
Any of these or other synonyms would be much more Swifty in my opinion.