Requiring Swift 5.3

In order to simplify testing and support, as well as adopt new language features internally, it's occasionally useful for Alamofire to bump its required Swift version without a major version bump. This occurred with Alamofire 5.2, which moved the required Swift version to 5.1 from 5.0. Since Apple only supports shipping App Store apps with the latest or latest - 1 versions of Xcode, there doesn't seem to be a big need for keeping Swift 5.1 and 5.2 compatibility. Really the only platforms affected would be old version of macOS on hardware that can't update to a newer version that supports Xcode 12 (at least macOS Catalina). So I've put up a PR to bump the required version to 5.3, which would go out as part of the next minor release.

Any thoughts?

Terms of Service

Privacy Policy

Cookie Policy