Request for quickie proposal and review


(Dave Abrahams) #1

Hi,

It occurred to us a couple weeks ago that the name `Value` was
a terrible name for the first parameter to `ManagedBuffer` et al, so I
prepared this patch that renames it to `Header`.

https://github.com/apple/swift/commit/eb7311de065df7ea332cdde8782cb44f9f4a5121

I would be immensely grateful if someone would like to volunteer to
write up a quick proposal for this change and pushing it the process.

TIA,

···

--
Dave


(Erica Sadun) #2

You got it.

Give me a few minutes

-- E

···

On Jun 28, 2016, at 8:04 PM, Dave Abrahams via swift-evolution <swift-evolution@swift.org> wrote:

Hi,

It occurred to us a couple weeks ago that the name `Value` was
a terrible name for the first parameter to `ManagedBuffer` et al, so I
prepared this patch that renames it to `Header`.

https://github.com/apple/swift/commit/eb7311de065df7ea332cdde8782cb44f9f4a5121

I would be immensely grateful if someone would like to volunteer to
write up a quick proposal for this change and pushing it the process.

TIA,

--
Dave

_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution


(Erica Sadun) #3

Dave:

I think this should be changed:

return withUnsafeMutablePointers { (v, e) in return body(v) }

should be

return withUnsafeMutablePointers { (h, e) in return body(h) }

-- E

···

On Jun 28, 2016, at 8:04 PM, Dave Abrahams via swift-evolution <swift-evolution@swift.org> wrote:

Hi,

It occurred to us a couple weeks ago that the name `Value` was
a terrible name for the first parameter to `ManagedBuffer` et al, so I
prepared this patch that renames it to `Header`.

https://github.com/apple/swift/commit/eb7311de065df7ea332cdde8782cb44f9f4a5121

I would be immensely grateful if someone would like to volunteer to
write up a quick proposal for this change and pushing it the process.

TIA,

--
Dave

_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution


(Erica Sadun) #4

Please look through:

https://gist.github.com/erica/af357a47ec5c1d26028769e1676af799

Let me know what corrections you want. Once you do so, I'll put it in as a pull request. Who do you want as the author
or should I put in "Administrative", "Core Team", or something similar?

-- E

···

On Jun 28, 2016, at 8:04 PM, Dave Abrahams via swift-evolution <swift-evolution@swift.org> wrote:

Hi,

It occurred to us a couple weeks ago that the name `Value` was
a terrible name for the first parameter to `ManagedBuffer` et al, so I
prepared this patch that renames it to `Header`.

https://github.com/apple/swift/commit/eb7311de065df7ea332cdde8782cb44f9f4a5121

I would be immensely grateful if someone would like to volunteer to
write up a quick proposal for this change and pushing it the process.

TIA,

--
Dave

_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution


(Dave Abrahams) #5

Dave:

I think this should be changed:

return withUnsafeMutablePointers { (v, e) in return body(v) }

should be

return withUnsafeMutablePointers { (h, e) in return body(h) }

Looks good.

···

on Tue Jun 28 2016, Erica Sadun <erica-AT-ericasadun.com> wrote:

-- E

On Jun 28, 2016, at 8:04 PM, Dave Abrahams via swift-evolution <swift-evolution@swift.org> wrote:

Hi,

It occurred to us a couple weeks ago that the name `Value` was
a terrible name for the first parameter to `ManagedBuffer` et al, so I
prepared this patch that renames it to `Header`.

https://github.com/apple/swift/commit/eb7311de065df7ea332cdde8782cb44f9f4a5121

I would be immensely grateful if someone would like to volunteer to
write up a quick proposal for this change and pushing it the process.

TIA,

--
Dave

_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

--
Dave


(Dave Abrahams) #6

Please look through:

https://gist.github.com/erica/af357a47ec5c1d26028769e1676af799

Let me know what corrections you want. Once you do so, I'll put it in
as a pull request.

I think the only thing needed is a reference to the patch

https://github.com/apple/swift/commit/eb7311de065df7ea332cdde8782cb44f9f4a5121

and removal of the notes about what needs auditing (since the patch
already takes care of it).

Who do you want as the author
or should I put in "Administrative", "Core Team", or something similar?

I'd like you to be the author, please!

···

on Tue Jun 28 2016, Erica Sadun <erica-AT-ericasadun.com> wrote:

-- E

On Jun 28, 2016, at 8:04 PM, Dave Abrahams via swift-evolution <swift-evolution@swift.org> wrote:

Hi,

It occurred to us a couple weeks ago that the name `Value` was
a terrible name for the first parameter to `ManagedBuffer` et al, so I
prepared this patch that renames it to `Header`.

https://github.com/apple/swift/commit/eb7311de065df7ea332cdde8782cb44f9f4a5121

I would be immensely grateful if someone would like to volunteer to
write up a quick proposal for this change and pushing it the process.

TIA,

--
Dave

_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

--
Dave