To the Swift community,
May I put forth a couple of new names for the following protocol:
- CustomStringConvertible — rename as ‘Descriptive’ or as ‘Revealable’
Two goals for Swift is clarity and joy in use of the language, so I strongly feel that ‘Custom-‘ not be part of any new name here since it contributes little except verbosity, and ‘-String-‘ should be dropped too since ‘CustomStringConvertible’ has nothing to do with the String struct proper. The protocol only consists of the var description, after all.
Of course, the corollary would be ‘DebugDescriptive’ or ‘DebugRevealable’
I did consider ‘Describable’ as a name but to me ‘Descriptive’ looks and sounds better and captures the essence of what CustomStringConvertible really is. ‘Revealable’ as an alternate sounds, pardon the pun, almost as descriptive and has a bit of a classier ring to it.
This is a followup, albeit partial, to the final review of proposal SE-0041 which noted that the community was quite positive about the stated need to rename this and some other protocols, but just needs agreement on new names.