The documentation on enumerations clearly reads,
Give enumeration types singular rather than plural names, so that they read as self-evident:
var directionToHead = CompassPoint.west
It looks like
CodingKeys is an exception to this. New adopters of Swift will encounter it and suppose that their own enumeration types should likewise have plural names.
CodingKey is already used as a protocol. We could rename either
What do you think?