Quick help for project elements?

Quick help (option-click) works fine on Xcode13 RC when examining library functions, but does nothing for local variables and functions / methods. Do I mis-understand what's expected of quick help? It makes no difference if I have documentation (cmd-option-/) for the element or not.

I too have noticed this regression relative to Xcode 12. I haven’t yet filed a bug about this (I will get there eventually!) but, regardless, I encourage you to create your own bug.

Keep in mind that Xcode is an Apple thing, so you’ll need to file the bug using Feedback Assistant.

Please post your bug number, just for the record.

Share and Enjoy

Quinn “The Eskimo!” @ DTS @ Apple

1 Like

I checked it this AM prior to filing a bug, and (Version 13.0 (13A233)) it’s fixed!



it’s fixed!

Cool. While I’m still having Quick Help problems with 13.0 RC (13A233), and it seems that I’m not the only one (r. 83232397), I’m glad to hear that it’s started behaviour for you.

Share and Enjoy

Quinn “The Eskimo!” @ DTS @ Apple

Hi Quinn, Xcode Version 13.0 (13A233) for Quick Help still does not work for me either. It seems like certain things work. I can select a func name (....) and click on the name, then I can use Commnd-click, and I get a menu. From that menu I can "Add Documentation". It adds information on the function with /// Declaration, parameters, returns, etc. Then I can fill them out, but when I select the function and try the Option-click, the Quick Help menu states "No Quick Help". But when I select one of the variables listed in the function, it will give the Quick Help Pop up. Is there something I'm missing, I've followed several documentation examples and web sites, but they don't work as advertised.... If you figure this out can you let me know... Thanks - Jim

O.K. after further investigation by using a MacBook Air with the M1 chip, I ran the same test code/project and it worked as advertised. So the exact same code passed on the M1 Xcode13 (13A233) and fails on the X86 Xcode13 (13A233). So I believe this is a real bug in the Intel X86 MacOS Xcode13.

This has started working for me too (testing with Xcode 13.1rc1 on macOS 11.6 on Intel).

I’m honestly not sure why it failed previously, or why you’re seeing different behaviour on different machines (although I suspect it’s not related to the CPU architecture but rather just two different machines that happen to have different CPU architectures).

Regardless, if you can nail down a reproducible case I’d appreciate you filing a bug about that.

Please post your bug number, just for the record.

Share and Enjoy

Quinn “The Eskimo!” @ DTS @ Apple

Hi Quinn,

Thanks for putting up with me for all of my questions in the past. I have three machines, a MacMini i7, a MacBook Air M1, and a iMac with an i9 CPU. Turns out it also runs fine on the iMac with an X86 I9 CPU. So it must be some problem with the installation of Xcode on the MacMini with the i7. I'll try and delete Xcode and reinstall a new copy. Sorry to bother everyone. I had gone to the
Apple Feedback, but have since said that it just seems to be that particular machine.

Thanks in Advance.

Reinstalling Xcode13 and rebooting the MacMini i7 worked and resolved the problem... I should of tried all the above before posting, so my humblest apologies to the Forum group. -Jim