Developers have been using Grand Central Dispatch to create asynchronous
code and optimize their applications. However, using GCD with Swift seems
unnatural due to the different naming conventions used. As a result, people
have been using wrappers for GCD instead, such as Async. I, for one,
created this simple wrapper for most used functions of Dispatch.
It would be nice if the Dispatch framework has a more Swift style
convention to make our codes cleaner.