`firstIndex` is completely unambiguous, whereas with `index` people might wonder which index is returned. Also, if `lastIndex` methods ever get added to the standard library, they will be a lot more consistent with `firstIndex` than with `index`.
On the other hand, `index` is short and simple, and people might not care whether it is the first index that matches or a different one. Still I think `firstIndex` is more in line with the naming guidelines.
On Jul 24, 2016, at 2:58 AM, Tim Vermeulen via swift-evolution <swift-evolution@swift.org> wrote:
`firstIndex` is completely unambiguous, whereas with `index` people might wonder which index is returned. Also, if `lastIndex` methods ever get added to the standard library, they will be a lot more consistent with `firstIndex` than with `index`.
On the other hand, `index` is short and simple, and people might not care whether it is the first index that matches or a different one. Still I think `firstIndex` is more in line with the naming guidelines.
On Jul 24, 2016, at 8:23 AM, Brent Royal-Gordon via swift-evolution <swift-evolution@swift.org> wrote:
On Jul 24, 2016, at 2:58 AM, Tim Vermeulen via swift-evolution <swift-evolution@swift.org> wrote:
`firstIndex` is completely unambiguous, whereas with `index` people might wonder which index is returned. Also, if `lastIndex` methods ever get added to the standard library, they will be a lot more consistent with `firstIndex` than with `index`.
On the other hand, `index` is short and simple, and people might not care whether it is the first index that matches or a different one. Still I think `firstIndex` is more in line with the naming guidelines.
> On Jul 24, 2016, at 2:58 AM, Tim Vermeulen via swift-evolution<swift-evolution@swift.org>wrote:
>
> `firstIndex` is completely unambiguous, whereas with `index` people might wonder which index is returned. Also, if `lastIndex` methods ever get added to the standard library, they will be a lot more consistent with `firstIndex` than with `index`.
>
> On the other hand, `index` is short and simple, and people might not care whether it is the first index that matches or a different one. Still I think `firstIndex` is more in line with the naming guidelines.
>
> Thoughts?
Working on it! https://github.com/brentdax/swift-evolution/blob/09be1007c5138be2370f33d761b05b8b6700a9a3/proposals/NNNN-sequence-end-ops.md
The latest comment from Brent on the PR indicated that it's ready, I
believe.
Jacob
···
On Sun, Jul 24, 2016 at 10:39 PM, Chris Lattner via swift-evolution < swift-evolution@swift.org> wrote:
> On Jul 24, 2016, at 2:41 PM, Dave Abrahams via swift-evolution < > swift-evolution@swift.org> wrote:
>
> Jose Cheyo Jimenez via swift-evolution <swift-evolution@...> writes:
>
>>
>> Is your proposal going to make the swift3 window?
>
> It should. I'm planning on merging it and launching the review
> if Chris L doesn't beat me to it (which I hope he will ;-)).
I’m still waiting to be told that it is ready. You guys appear to still
be iterating in the PR.