I’d say it’s demonstrably an issue.
The answer was not conditional conformance, the answer was to decline that particular proposal. The problem that the proposal tried to solve is still unsolved.
Reading the post you link to, we see that “there was enough consensus on the review thread that the current name of the API can be misinterpreted”, but the core team decided, after weighing a couple of factors, to keep the current name and thus the current situation, which is said to be “mitigated somewhat by the ability to consistently use == now that conditional conformances have been adopted (where appropriate) for Standard Library types”.
elementsEqual-issue, and the situation described in the original post of this thread:
has not been addressed.
This attempted solution is just further underlining the problem. Note the family of methods that
isSuperset(of: )is part of:
isSubset(of: ) isStrictSubset(of: ) isSuperset(of: ) isStrictSuperset(of: ) ...
So changing the name of one of those would just be adding more drama.
And what about
I think the issue affects both activities (using the language to write apps and extending the language, or rather the standard library, with new functionality). I’m not sure that such a categorization/division of activities can/should be made. I’m sorry if I misunderstand your question.