Module compiled with swift 5.3.2, may have used features that aren't supported by this compiler, 'Apple Swift version 5.3

I have created my custom framework that was built with Xcode 12.4 using aggregates. I have also enabled Build Libraries for Distribution in build settings of my framework and also add SKIP_INSTALL=NO in run script.

I am trying to use that framework in Xcode 12.0.1 in a new project . I have successfully added that framework, but when I write import FrameworkName in ViewController, I get the following error:

Failed to build module the compiler that produced it, 'Apple Swift version 5.3.2, may have used features that aren't supported by this compiler, 'Apple Swift version 5.3

Is it something we can fix without switching to a different Swift version?

Terms of Service

Privacy Policy

Cookie Policy