minimum deployment target


(J.E. Schotsman) #1

Hello,

I have some code that is used in both a project with minimum deployment target 10.9 and a project with minimum deployment target 10.11.
If I check for availability of API’s on the 10.9 project I get warnings on the 10.11 project saying these checks are unnecessary.
Can I conditionalize this check somehow?

Jan E.


(Zhao Xin) #2

Maybe you should ask this question in
https://forums.developer.apple.com/welcome

Zhaoxin

···

On Mon, Nov 14, 2016 at 6:26 PM, J.E. Schotsman via swift-users < swift-users@swift.org> wrote:

Hello,

I have some code that is used in both a project with minimum deployment
target 10.9 and a project with minimum deployment target 10.11.
If I check for availability of API’s on the 10.9 project I get warnings on
the 10.11 project saying these checks are unnecessary.
Can I conditionalize this check somehow?

Jan E.
_______________________________________________
swift-users mailing list
swift-users@swift.org
https://lists.swift.org/mailman/listinfo/swift-users