It's not possible to compile a project; Podfile.lock no such file or directory

I'm new in Xcode and Swift.
I cloned a private project from my job as a developer.

The problem is there's a problem to compile the project. A Shell Script Invocation Error:

No such module 'PopupDialog'

If I try to fix manually this errors, the Swift Compile Error now is below:

diff: /../Podfile.lock: No such file or directory
diff: /Manifest.lock: No such file or directory
error: The sandbox is not in sync with the Podfile.lock. Run 'pod install' or update your CocoaPods installation.
  • I installed Xcode latest from Apple Store
  • I downloaded the lasted Swift from website/releases

Environments:

  • MacOS High Sierra 10.13.6
  • XCode 9.4.1
  • Apple Swift version 4.1.2 (swiftlang-902.0.54 clang-902.0.39.2)
    Target: x86_64-apple-darwin17.7.0

For the project Workspace, there's a convertion to Swift 4 available, but if I do it, theres a tooltip message on center of screen with Build failed message.

  • The BaseSDK is `Latest iOS (iOS 11.4)
  • The iOS Deployment Target is iOS 9.3
  • The Swift Language Version to compile is Unspecified

Please I need a help to get started with XCode and build this projects.

References:

You likely need Cocoapods to install dependencies.
gem install cocoapods then pod install in your project root directory (there's should be a Podfile and Podfile.lock file there).

I receive the SwiftMessages error when try to download it.

$ pod install
Analyzing dependencies
Pre-downloading: `SwiftMessages` from `https://github.com/SwiftKickMobile/SwiftMessages.git`, commit `2b398660759bc08afcda725c0c95305e674d21f0`

[!] Error installing SwiftMessages
[!] Failed to download 'SwiftMessages

In the Podfile has a SwiftMessages mention:

pod 'SwiftMessages', git: 'https://github.com/SwiftKickMobile/SwiftMessages.git', branch: 'swift3'

I followed this instructions as well:

And when I run gem which cocoapods:

/Users/<MY-USER>/.gem/ruby/2.3.0/gems/cocoapods-1.5.3/lib/cocoapods.rb

Error is not very relevant here, but seems branch "swift3" does not exist anymore on SwiftMessages.
You should use a tagged version instead, pod 'SwiftMessages', '3.5.1' for example which I think should be compatible with swift3.

Also, you have to specify swift3 for Swift Language Version to make it compile successfully.

1 Like

Thank you for help me!

I''l investigate now for this argument errors:

unknown argument: '-enforce-exclusivity=checked'
<unknown>:0: error: unknown argument: '-index-store-path'
<unknown>:0: error: unknown argument: '-swift-version'
<unknown>:0: error: unknown argument: '-pch-output-dir'

Step 1

I downloaded the Xcode 8.3 old version and defined it and Toolchains menu option as well but before, I run a fell commands on console:

Define the Xcode version:

~$ sudo xcode-select --switch /Applications/Xcode\ 8.3.app

And now you can prove the Swift configurated:

$ swift -version
Apple Swift version 3.0 (swift-3.0-RELEASE)
Target: x86_64-apple-macosx10.9

I run pod clean and pod install and it's ok.

The step two of the problem is on No such module PopupDialog

hi, For me Solved: with XCODE, IOS, IONIC, CORDOVA
1 - in xcode las var of config build in user-defined
in xcode change value of $(SRCROOT) for you root project [enter image description here]!

[enter image description here]


2 - changed var in this clic in the plus of up:
for%20stracoverflow|690x111

nota: root project is: location of my project and location where use pod this my firs question thank for watching

Terms of Service

Privacy Policy

Cookie Policy