How to set swift-DEVELOPMENT-SNAPSHOT-2016-03-24-a as default version in the commandline on OSX 10.11.4?


(Norbert Fuhs) #1

Hi I'm new to coding in Swift and I use an Mac with also ubuntu on it and
have a strange problem:

On ubuntu 15.10 I could install the latest Swift Version without any
problems and
If i do swift --version it shows its the latest trunk release with Swift
Package Manager 0.1

On OS X i installed all the .pkg files and I can change to this version in
Xcode
and I put the following into .profile:

# Swift Toolchain Variables

export
PATH=/Library/Developer/Toolchains/swift-DEVELOPMENT-SNAPSHOT-2016-03-24-a.xctoolchain/usr/bin:"${PATH}"

When i do swift --version on OS X i only get:

Apple Swift version 2.2 (swiftlang-703.0.18.1 clang-703.0.29)
Target: x86_64-apple-macosx10.9

Is there somewhere a tutorial or guide how to change the swiftversion on
OSX or is the are tool for this?

Thanks for the help.