Error running `utils/update-checkout --clone-with-ssh`

I am attempting to follow the Getting Started instructions at swift/docs/HowToGuides/ at main · swiftlang/swift · GitHub.

When I run utils/update-checkout --clone-with-ssh

I get the error listed below attempting to checkout out the icu project.

Is this a known error?
Is there a workaround?

Thanks in advance for any assistance.

Traceback (most recent call last):
  File "/Applications/", line 125, in worker
    result = (True, func(*args, **kwds))
  File "/Applications/", line 48, in mapstar
    return list(map(*args))
  File "/Users/myhome/Developer/swift-project/swift/utils/update_checkout/update_checkout/", line 393, in obtain_additional_swift_sources['git', '--git-dir',
  File "/Users/myhome/Developer/swift-project/swift/utils/swift_build_support/swift_build_support/", line 257, in run
    raise eout
Exception: ['git', '--git-dir', '/Users/myhome/Developer/swift-project/icu/.git', '--work-tree', '/Users/myhome/Developer/swift-project/icu', 'checkout', 'maint/maint-69']

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/Users/myhome/Developer/swift-project/swift/utils/update-checkout", line 15, in <module>
  File "/Users/myhome/Developer/swift-project/swift/utils/update_checkout/update_checkout/", line 721, in main
    clone_results = obtain_all_additional_swift_sources(args, config,
  File "/Users/myhome/Developer/swift-project/swift/utils/update_checkout/update_checkout/", line 461, in obtain_all_additional_swift_sources
    return run_parallel(
  File "/Users/myhome/Developer/swift-project/swift/utils/update_checkout/update_checkout/", line 49, in run_parallel
    results = pool.map_async(func=fn, iterable=pool_args).get(999999)
  File "/Applications/", line 771, in get
    raise self._value
Exception: ['git', '--git-dir', '/Users/myhome/Developer/swift-project/icu/.git', '--work-tree', '/Users/myhome/Developer/swift-project/icu', 'checkout', 'maint/maint-69']

I believe it's this one.

1 Like

Thank you @vanvoorden. The workaround listed in the issue of skipping checking out the ICU project avoided the error.

1 Like

@James_Dempsey Want to help land this diff to update the instructions?

@vanvoorden I'm not sure what I am able to do since I don't have commit access to the repository. I left a review note that the workaround worked for me on macOS as of yesterday.

1 Like