DocC for Objective-C static library

I know with Xcode 14 there is support for Objective-C documentation in DocC. Is that only available for Objective-C code in an app project? I have a static library that is Objective-C only that I am trying to generate documentation for but nothing gets generated at all, trying to figure out what I am doing wrong to get this to generate correctly. I didn't see any build settings that stood out as a reason it wouldn't be generating, if I add a Swift file to the library it will generate documentation for the Swift file but still ignore the Objective-C code. Any guidance here would be greatly appreciated

Would you be able to file a feedback providing as many details about your project as you can? Also Objective-C support only extracts documentation from headers marked as public in the Xcode project, maybe this is what you are running into?

Yea I can file a feedback and provide a sample project I setup that demonstrates the issue. I don't believe the issue is with the headers not being public, I have tried both a static library and objective-c based SPM package with public (tested by importing and using them in a project) and they wont generate documentation so it seems like there may be an issue here, and I can't find any example projects showing the generation of objective-c documentation in either of these scenarios.

We haven't completed support for Objective-C in SPM. I will make a post once that work is complete.

Also found the same issue as the author described. I am in an SDK team building Swift/Objective-C libraries. For Objective-C projects the DocC on Xcode 14.1 generates nothing but API document on Swift based dependency. This is not related to public headers - we have extensive documents available on public headers, which can be shown correctly in Xcode -> Show Quick Help.

Looking forward to that. Most of my team's SDK projects (OC & Swift) are based on both SPM and CocoaPods. Currently OC projects cannot get the documentation from DocC.

Looking forward to your good news

Hello, we have the same problem in my team, both mixed Objective-C and swift for our framework, I just found out that it works only if the Objective-C public header are imported as a module in the public umbrella, if they double quoted, it will not work. We need to import our headers with double quoted format for our project. Anyone have the same issue?

Are your headers public and belong to the correct target?

Yes they are public and belong to the correct target, found out that the objective-c files are documented but only in the swift language ( when we select swift in the documentation app) and with imports as module, it works for both swift and objective-c language.

Can you file a feedback on Feedback Assistant on "Developer Tools & Resources" for the area "DocC Documentation", if possible can you add your Xcode project or an Xcode project that can reproduce the issue? Also if you could DM the feedback so I can find it more easily that would be perfect.

Coming with updates : The problem is solved by changing only the double quoted style to module style from example #import "class.h" to #import <class.h>.

Would you still be able to upload a feedback? I am not entirely sure what your project setup looks like but we should be able to handle all include styles that would work in a regular build.

I will try to create a project tomorrow to show case the missing documentation , so even with the module import style, the framework dosen't work when embedded in an app so the trick did not work well.

Hi @daniel-grumberg , i have sent a feedback under the name "DocC Documentation for mixed swift and objective-c framework." with a concept project.

We've run into the documentation not rendering in objective-c format for mixed swift and objective-c framework. @daniel-grumberg Wondering if this issue has been reproduced, and potentially resolved?