Compiler failure when trying to build the new swift-collections

I cloned down the new swift-collections repository and went to open it up, explore a bit. First thing I tried was opening it in Xcode 12.4 (Intel Mac), and when I did a fresh build, I got a compiler failure/crash.

I thought maybe there was a different with swift directly on the command line, so I tried there - but hit basically the same thing.

Is this something I should open a bug for, or am I holding it wrong?

The failure is in swift-collections-CLI-build-failure.txt · GitHub - I didn't to spam it into here, but the key error message seems to be:

<unknown>:0: error: fatal error encountered while reading from module 'OrderedCollections'; please file a bug report with your project and the crash log
<unknown>:0: note: module 'OrderedCollections' full misc version is '5.3.2(5.3.2)/Apple Swift version 5.3.2 (swiftlang-1200.0.45 clang-1200.0.32.28)'

To be on the safe side, I opened a bug for this: https://bugs.swift.org/browse/SR-14448. Happy to close it mea culpa if I'm missing something and just "holding it wrong"

1 Like

That's definitely not how it should work! Please open a bug if you can; meanwhile I'll try to reproduce it locally to see what's going on.

I was able to snag an M1 MacBook, and it worked brilliantly there - no issue, so the issue may be related to Intel - in either case, it's filed as https://bugs.swift.org/browse/SR-14448

1 Like

Thank you, we're looking into it!

It looks like others are hitting the same issue: Fails to compile (Abort trap: 6) · Issue #7 · apple/swift-collections · GitHub

FWIW, if you're hitting this there is a workaround suggested by @lorentey (in the bug report) that's functioning: compile it with -c release.

1 Like
Terms of Service

Privacy Policy

Cookie Policy