Change the name of the boolean operators?


(Sean Heber) #1

I would like to propose that &&, ||, !, etc are replaced with keywords such as “and”, “or”, “not”, etc. As small as this may seem, it is one of my favorite things about Python that, IMO, can dramatically improve readability.

l8r
Sean


(Chris Lattner) #2

Hi Sean,

We’ve briefly considered this in the past. However, this doesn’t align well with the design of swift, which partitions infix and prefix operators into their own namespace (composed of operator characters) and normal identifiers (composed of “identifier characters”). You can see the grammar for this in the Swift Programming Language Reference.

-Chris

···

On Dec 3, 2015, at 2:19 PM, Sean Heber <sean@fifthace.com> wrote:

I would like to propose that &&, ||, !, etc are replaced with keywords such as “and”, “or”, “not”, etc. As small as this may seem, it is one of my favorite things about Python that, IMO, can dramatically improve readability.