Cannot build swift: SELF-SOLVED

gsoc-2019
(Keita Nonaka) #1

I cannot build swift.
I followed README on GitHub: https://github.com/apple/swift#building-swift
However, terminal says -bash: utils/build-script: No such file or directory

I installed cmake and ninja
brew install cmake ninja

and cloned code git clone https://github.com/apple/swift.git
./swift/utils/update-checkout --clone

Could you tell me how to run utils/build-script --release-debuginfo and/or build swift?
Thanks

--SELF SOLVED--
cd swift
utils/build-script --release-debuginfo

(Kyle Murray) #2

How much familiarity do you have with bash?

To me the error is indicating either 1) you’re not running the command from the right directory, or 2) you haven’t cloned the swift repository where the build script lives.


After running git clone, you should run cd swift if you’re going to refer to the utils directory without qualification.

(Keita Nonaka) #3

I am familiar with bash.
I didn't know where utils/build-script is, but I solved the problem.

Thanks.

(Kyle Murray) #4

Glad you solved it! I must have been typing a response during your debugging. :sweat_smile:

(Keita Nonaka) #5

Thanks!
You're fine. I should have be more careful.