App Crash in dyld: Library not loaded: @rpath/libswiftCore.dylib

App crash when I run the app. Build was success but crash happened right after the splash screen. It's shows complier like

dyld: Library not loaded: @rpath/libswiftCore.dylib
** Referenced from: /private/var/containers/Bundle/Application/2B049AF9-C589-4DB5-8E35-8E3C31E7FA07/**
** Reason: image not found**
Message from debugger: Terminated due to signal 6

I have no idea how to fix this issue. My configurations are,

Mac OS - Mojave 10.14.5
Xcode - 10.2.1

NOTE: This app runs fine in XCode 10.1 and crash happens only on Xcode 10.2 and Xcode 10.2.1


Have you tried cleaning the DerivedData folder? I ran into this issue multiple times, and deleting DerivedData usually helped

Hi Broadway,
Thanks for the info. I have already cleared the derived data multiple times. But still it's crashing. :frowning:

did you know any other way ?

Unfortunatley, no :(

I have spent more than 2 days but still I can't not find the solution. This happens only xCode 10.2.1.

It’s usually something wrong with the project setting. In this case, it’s likely you need to embed the swift runtime but you didn’t.

I’d suggest that you create a new project, and keep moving the files over, recompiling/rerunning during the process.