This is more an announcement to make people aware but happy to open it up to discussions. Over the last week or so, there have been two developments that will make the case for dropping support for macOS 10.14 compelling.
Note - this has no effect for any Linux distros
First - Apple released the new Swift Crypto library last week which has a minimum requirement of 10.15 due to it being built on top of CryptoKit. Whilst there has been some discussion about using BoringSSL to polyfill to older macOS versions, this doesn't seem likely, at least in the short term. Vapor really, really, really does not want to maintain it's own Crypto library and using a shared, 'recommended', Crypto library across all of server-side Swift has much the same benefits as everyone using NIO. This also allows Vapor to completely remove any dependency on OpenSSL, which would make it easier for people to build Vapor projects.
Second, Xcode 11.4 Beta was released yesterday which includes the first Xcode integrated version of Swift 5.2. It's likely that Vapor 4 will require Swift 5.2 and since Xcode 11.4 requires macOS 10.15, it provides another reason to make Vapor 4, 10.15 and greater.