[Amendment] SE-0430: `sending` parameter and result values

Hello Swift community,

The review for an amendment to SE-0430: sending parameter and result values begins now and runs through June 28, 2024.

The amendment brings UnsafeContinuation.resume(returning:) into line with CheckedContinuation.resume(returning:) by marking its parameter sending. The authors have added a new subsection of "alternatives considered" to explain why they believe this design is preferable.

Reviews are an important part of the Swift evolution process. All review feedback should be either on this forum thread or, if you would like to keep your feedback private, directly to the review manager by email. When emailing the review manager directly, please include "SE-0430" in the subject line.

What goes into a review?

The goal of the review process is to improve the proposal under review through constructive criticism and, eventually, determine the direction of Swift. When writing your review, here are some questions you might want to answer in your review:

  • What is your evaluation of the proposal?
  • Is the problem being addressed significant enough to warrant a change to Swift?
  • Does this proposal fit well with the feel and direction of Swift?
  • If you have used other languages or libraries with a similar feature, how do you feel that this proposal compares to those?
  • How much effort did you put into your review? A glance, a quick reading, or an in-depth study?

More information about the Swift evolution process is available at

swift-evolution/process.md at main · apple/swift-evolution · GitHub

Happy reviewing,

—Becca Royal-Gordon
SE-0430 Review Manager


This change is reasonable to me and makes sense in context. :ship:


Totally makes sense. +1

nit: swift-evolution/proposals/0430-transferring-parameters-and-results.md at main · swiftlang/swift-evolution · GitHub still claims it's spelled sendable and not sending and argues why sending isn't a good spelling :slight_smile: .

Along the same lines, should the heading "Sendable Values and Sendable Types" be changed to something like " Sendable Types and Sending Values"?


The Language Steering Group has decided to accept this amendment. See the announcement for more details.