[Accepted with revisions] SE-0184: Unsafe[Mutable][Raw][Buffer]Pointer: add missing methods, adjust existing labels for clarity, and remove deallocation size

Hello Swift community,

Proposal Link: https://github.com/apple/swift-evolution/blob/master/proposals/0184-unsafe-pointers-add-missing.md

The review of SE-0184 "Unsafe[Mutable][Raw][Buffer]Pointer: add missing methods, adjust existing labels for clarity, and remove deallocation size” officially ran September 1…7, 2017. It was a large proposal for which most parts received a lot of support, while other parts were contentious. The proposal is accepted with revisions:

* Partial initialization/assignment will be removed from this proposal and discussed separataely
* Some argument labels will be changed for clarity (“bytes” -> “byteCount”, “alignedTo” -> “alignment”)
* The “count” argument to deallocate() will be removed entirely

The proposal has already been updated to reflect these changes. Thank you to the proposal author and everyone who participated in the discussion.

  Doug,
  Review Manager