The review of SE-0214 has concluded and the proposal has been accepted with a revision.
In the review thread discussion, many names were considered, and the core team agreed that
KeyValuePairs is a best name suggested on the thread for this type.
Thank you to everyone who contributed to this discussion and for Erica Sadun and Chéyo Jiménez for driving this proposal. Erica, Chéyo, if you have time, please update the implementation PR and there may still be time to get it into Swift 4.2.
Thank you so much!