The discussion of SE-0197 made it clear that there is consensus in the community to add the feature. However, several people expressed concern about using the base name
remove, since it’s ambiguous about how many matching elements will be removed. There seemed to be broad agreement that
removeAll would be a better name, with no objections raised during the review. Accordingly, the core team has decided to accept the proposal with the revision that the method be named
We expect this feature to be available in Swift 5.
As always, thank you for helping to make Swift a better language.