[Accepted with modification] SE-0258: Property Wrappers

The third review of SE-0258 has concluded. There was a lot more great discussion in this review, and while there were some questions and reservations, overall the community expressed strong support for accepting the proposal. The Core Team agrees and has decided to accept SE-0258 with only one minor change: we would like to accept the community's suggestion that the initialValue: argument label on wrapper initializers be renamed to wrappedValue: to match the property name. The Core Team feels that this is a minor enough change to make without a further round of review.

This has been a long and fruitful evolution review, encompassing three separate formal review periods and quite a few rounds of pitching and redevelopment. As the review manager, I appreciate how the community has handled itself throughout this process. It is a goal of evolution to not merely pass judgment on proposals but to ensure that they are as good as they can be, and I think SE-0258 has been a model for that in many ways. We now have a far better language design than we started with, and for that the credit goes both to the adaptability and patience of the authors and to the persistence and energy of the community. By thinking hard about the feel of the feature, by pushing on its expressive potential, and by actually trying it out and relaying back its strengths and weaknesses, the community has shaped and improved it immeasurably.

I say this in every review, and I mean it honestly: thank you for helping to make Swift a better language.

John McCall
Review Manager


6 posts were merged into an existing topic: Question about nested property wrappers and mutability