Feedback in the second round of review was generally positive. There was a fair amount of discussion about the new names, and people seemed to generally approve of the name
Sendable for the protocol. Consensus was weaker about the name
@sendable for the function-type attribute; the Core Team discussed this and decided to steal an idea from Matthew Johnson and rename the attribute to
@Sendable. This name better emphasizes the core idea of the attribute (that so-modified function values have to conform to
Sendable, and thus their captures must, too), and it also aligns with an interesting future direction (to allow similar protocol-based constraints on specific function types). The review was briefly extended, and feedback on that rename was strongly positive. Accordingly, SE-0302 is accepted with that modification.
Thank you for helping make Swift a better language.