Xcode Error - Failed to inherit CoreMedia permissions

Progressing through Paul Hudson's Hacking With Swift book, currently working through project 16 which has to do with JavaScript Injection and Safari extensions. It's a simple app that I've completed in the past but now, when I select the extension in Safari's activity controller. I get the following error output within the console:

`2018-05-29 19:46:51.122947-0400 Extension[99971:6052623] Failed to inherit CoreMedia permissions from 99961: (null)`

There aren't many support threads I could find about this topic, but there are half a dozen "fixes" in each thread that simply haven't worked, ranging from managing the project's App Groups, resetting constraints within IB, managing targets for the Assets directory, and more.

What am I doing wrong? What haven't I setup correctly within Xcode? Any help is of course greatly appreciated.

If it's helpful at all, feel free to check the files here. For reference, I'm also getting the same error running the completed project from his personal repo.

1 Like


The Swift forums are more geared towards the language itself, rather than Xcode or Apple tools. I’ve moved your question to the Using Swift forum in case someone can help provide a good answer—the Development forum is for development of Swift core libraries (Foundation, Dispatch, XCTest), not development with core libraries (which, incidentally, do not include Apple’s libraries prefixed with “Core”). Cheers,


No worries -- I appreciate the redirect!

Hi Matt -
Thx for asking. Now I know I'm not alone. :smile:

I also found several fixes that don't, and I'm learning iOS/Swift too. I created a new iMessage app & extension with Xcode 9, and fresh out of the gate saw a similar error:

2018-06-11 05:30:31.552176-0700 MyApp MessagesExtension[38028:3783980] 
Failed to inherit CoreMedia permissions from 38025: (null)

After looking at it for a bit, thought those looked like process IDs.

Yep, sure enough:

fathead:myApp me$ ps -ef | grep 38028
  502 38028 38029   0  5:30AM ??         0:01.11 /Users/me/Library/Developer/CoreSimulator/Devices/81232B0F-0666-4CE1-AABC-DD9153052512/data/Containers/Bundle/Application/29EE73DC-6A57-4F5E-9256-3E19329DA99B/MyApp.app/PlugIns/MyApp MessagesExtension.appex/MyApp MessagesExtension

fathead:myApp me$ ps -ef | grep 38025
  502 38025 35287   0  5:30AM ??         0:03.06 /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/Library/CoreSimulator/Profiles/Runtimes/iOS.simruntime/Contents/Resources/RuntimeRoot/Applications/MobileSMS.app/MobileSMS 

Summary: the app extension (#38028) failed to get "CoreMedia permissions" from the iPhone Simulator (#38025).

I have no clue how to fix, but certainly a frustrating puzzle from a bone stock sample Swift-based application created by Xcode!

(Edited to simplify the paths, and double-checked that brand new app/extension does this reproducibly.)