Vector, a fixed-size array

"Inline" is an adjective. I like nounifying adjectives, verbing nouns etc. as much as anyone, but I don't think it works well in this case -- I would very much prefer not to say that a function returns an "inline of 3 integers"!

Good names also work well in contexts where there is no code voice.

(Additionally, remember that we intend to use Inline as the standard naming prefix for data structure variants with inline storage:

  • InlineArray<Capacity, Element>,
  • InlineSet<Capacity, Element>,
  • InlineDeque<Capacity, Element>,
  • InlineDictionary<Capacity, Key, Value>,
  • InlineString<Capacity> (?!)
  • etc. etc.

The vector type we're proposing is not a member of this family, and it isn't much related to any of these. Reusing their prefix as a standalone name would not be helpful, I think.)

12 Likes