Using sourcekit-lsp on Ubuntu 18.10

Okay, I was excited to see that but unfortunately it didn't seem to help. I'm now on Swift 5.1 (5/29), latest commit on master for sourcekit-lsp. I deleted my build folder and sourcekit-lsp works fine, no matter how many times I reopen VSCode. But once I build, the server crashes.

@blangmuir is it possible to add pre-release on GitHub with pre compiled binaries, i.e

or is sourcekit-lsp will be going to bundled with swift snapshots in future?

Our plan is to bundle it with the toolchain in the future. I'm hoping to work on this "soon".

1 Like

I went back to a commit on which it worked for me, and it doesn't work anymore ¯\_(ツ)_/¯

Hmm, alright. It’s not the end of the world, but it’s definitely an inconvenience. I’m surprised this issue isn’t more common though. Hoping for a fix soon

I found a minimal reproducer for SR-10319 , which appears to be a corelibs-libdispatch bug. I'm going to put in a workaround: https://github.com/apple/indexstore-db/pull/27

1 Like

@atyshka @cukr The workaround is in, so please try again with the latest master (or swift-5.1-branch) of sourcekit-lsp. Make sure to run swift package update to get the latest sources for indexstore-db as well before building. Let me know if you're still seeing an issue.

1 Like

trying to build current master after running swift package update gave me an error (should I try to reproduce it and maybe fill a bug report?)

error

cukier@papryka:~/Developer/sourcekit-lsp$ /home/cukier/Developer/swift-5.1-DEVELOPMENT-SNAPSHOT-2019-05-29-a-ubuntu18.04/usr/bin/swift build -Xcxx -I/home/cukier/Developer/swift-5.1-DEVELOPMENT-SNAPSHOT-2019-05-29-a-ubuntu18.04/usr/lib/swift/
:0: error: module compiled with Swift 5.0 cannot be imported by the Swift 5.1 compiler: /home/cukier/Developer/sourcekit-lsp/.build/x86_64-unknown-linux/debug/SPMLibc.build/libc~partial.swiftmodule
failed parsing the Swift compiler output: invalid message size
[81/170] Compiling libllbuild C-API.cpp

but after removing .build directory everything seems to work perfectly! <3

@Aciid worth a bug report for the above? Seems like an incremental build correctness issue when changing toolchains.

Yes, please file a bug!

thanks, same error happend with Ubuntu 19.10. solved by installing libtinfo5 and libncurses5

1 Like

i think Ubuntu 16.04, which ships libtinfo.so.5 , while it looks like the latest Ubuntu ships with libtinfo.so.6 .

Terms of Service

Privacy Policy

Cookie Policy