SwiftNIO SSL and SwiftUI

I think, that this is more an issue with SwiftUI and Xcode then with SwiftNIO, but I wanted to ask, if someone else has problems when using SwiftNIO SSL with a Mac Catalyst project, that uses SwiftUI. The issue: I cannot see the previews because of the following error:

The package product 'CNIOBoringSSL' requires minimum platform version 10.15 for the macOS platform, but this target supports 10.10 (in target 'NIOSSLHTTP1Client' from project 'swift-nio-ssl')

Interestingly it works, if I disable the Mac platform and only use iOS or if I choose a iOS-device from the target menu.