Swift Soars Ever Higher

Hi @pvieito!

Glad to hear that!

This is partially correct. You should be using -sdk instead of -resource-dir. The problem here is that I need to find and revive an old patch of mine which would actually result in this being collapsed into a single flag: -sdk. I'm not convinced that having a single flag to add the SDK search paths to the compiler driver is a bad thing - defaulting that via an environment variable like SDKROOT is certainly possible and reasonable, but I suspect that some people may be unhappy about the environment variable impacting the compilation process (and I can completely empathize - its very easy to get something injected without realizing it).

That is technically unrelated to the Swift project and is a request for Visual Studio. I would recommend that you file a Developer Community for improvements there. Note that Visual Studio 2019 has a Developer PowerShell for VS 2019 option but that is x86 only. I don't know what the plans are around providing an environment that works for x64 and ARM64 development within PowerShell. For now, I highly recommend cmd as the working environment.

Yes, it is possible to run the REPL on Windows, I've definitely been able to use it. The error that you are seeing is something new and not something that I am aware of unfortunately. Perhaps @JDevlieghere might be able to shed some light on that.

CC: @JDevlieghere

1 Like

I was looking at something related to this, I suspect that something has changed in lldb where the implementation refactored the POSIX path but failed to account for Windows and has regressed this. It requires a bit of work to support loading modules.

A relatively horrible workaround that should work for the time being:

lldb "--repl=-sdk C:\Library\Developer\Platforms\Windows.platform\Developer\SDKs\Windows.sdk -target x86_64-unknown-windows-msvc"
1> :expr (void*)LoadLibraryA("swiftCore.dll")

With this I'm able to do something like this:

2 Likes
Terms of Service

Privacy Policy

Cookie Policy