Swift.org RSS Feed appears broken


(Neil Tiffin) #1

Hello all,

What is the correct place to report that swift.org rss feeds are broken? The feed does not work with Vienna on OS X and fails W3C validation.

Thanks,

Neil

https://validator.w3.org/feed/check.cgi?url=feed%3Ahttps%3A%2F%2Fswift.org%2Fatom.xml

···

————————————————————————————————————————————
Sorry

This feed does not validate.
  • line 15, column 21: id must be a full and valid URL: /blog/welcome (9 occurrences) [help]
    <id>/blog/welcome</id>
                     ^
  • line 54, column 2: Missing entry element: author (9 occurrences) [help]
  </entry>
  ^
In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
  • Your feed appears to be encoded as "utf-8", but your server is reporting "US-ASCII" [help]

  • line 4, column 65: Relative href value on self link: /atom.xml [help]
  <link type="application/atom+xml" href="/atom.xml" rel="self"/>
                                                                 ^


(Jordan Rose) #2

bugs.swift.org <http://bugs.swift.org/>, category "Project Infrastructure". Thanks for reporting this!

Jordan

···

On Mar 22, 2016, at 5:53, Neil via swift-users <swift-users@swift.org> wrote:

Hello all,

What is the correct place to report that swift.org rss feeds are broken? The feed does not work with Vienna on OS X and fails W3C validation.

Thanks,

Neil

https://validator.w3.org/feed/check.cgi?url=feed%3Ahttps%3A%2F%2Fswift.org%2Fatom.xml
————————————————————————————————————————————
Sorry

This feed does not validate.
  • line 15, column 21: id must be a full and valid URL: /blog/welcome (9 occurrences) [help]
   <id>/blog/welcome</id>
                    ^
  • line 54, column 2: Missing entry element: author (9 occurrences) [help]
</entry>
^
In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
  • Your feed appears to be encoded as "utf-8", but your server is reporting "US-ASCII" [help]

  • line 4, column 65: Relative href value on self link: /atom.xml [help]
<link type="application/atom+xml" href="/atom.xml" rel="self"/>
                                                                ^

_______________________________________________
swift-users mailing list
swift-users@swift.org
https://lists.swift.org/mailman/listinfo/swift-users


(Ted Kremenek) #3

Hi Neil,

Aside from the encoding issue (which we are looking into), this should now be fixed. Can you check on your end?

Thanks,
Ted

···

On Mar 22, 2016, at 5:53 AM, Neil via swift-users <swift-users@swift.org> wrote:

Hello all,

What is the correct place to report that swift.org rss feeds are broken? The feed does not work with Vienna on OS X and fails W3C validation.

Thanks,

Neil

https://validator.w3.org/feed/check.cgi?url=feed%3Ahttps%3A%2F%2Fswift.org%2Fatom.xml
————————————————————————————————————————————
Sorry

This feed does not validate.
  • line 15, column 21: id must be a full and valid URL: /blog/welcome (9 occurrences) [help]
   <id>/blog/welcome</id>
                    ^
  • line 54, column 2: Missing entry element: author (9 occurrences) [help]
</entry>
^
In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
  • Your feed appears to be encoded as "utf-8", but your server is reporting "US-ASCII" [help]

  • line 4, column 65: Relative href value on self link: /atom.xml [help]
<link type="application/atom+xml" href="/atom.xml" rel="self"/>
                                                                ^

_______________________________________________
swift-users mailing list
swift-users@swift.org
https://lists.swift.org/mailman/listinfo/swift-users


(Kevin Lundberg) #4

I saw the latest 2.2 announcement post in my reader yesterday, so it does appear to be fixed.

Kevin Lundberg
kevin@klundberg.com

···

On Mar 24, 2016, at 1:18 PM, Ted Kremenek via swift-users <swift-users@swift.org> wrote:

Hi Neil,

Aside from the encoding issue (which we are looking into), this should now be fixed. Can you check on your end?

Thanks,
Ted

On Mar 22, 2016, at 5:53 AM, Neil via swift-users <swift-users@swift.org <mailto:swift-users@swift.org>> wrote:

Hello all,

What is the correct place to report that swift.org <http://swift.org/> rss feeds are broken? The feed does not work with Vienna on OS X and fails W3C validation.

Thanks,

Neil

https://validator.w3.org/feed/check.cgi?url=feed%3Ahttps%3A%2F%2Fswift.org%2Fatom.xml <https://validator.w3.org/feed/check.cgi?url=feed%3Ahttps%3A%2F%2Fswift.org%2Fatom.xml>
————————————————————————————————————————————
Sorry

This feed does not validate.
  • line 15, column 21: id must be a full and valid URL: /blog/welcome (9 occurrences) [help]
   <id>/blog/welcome</id>
                    ^
  • line 54, column 2: Missing entry element: author (9 occurrences) [help]
</entry>
^
In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
  • Your feed appears to be encoded as "utf-8", but your server is reporting "US-ASCII" [help]

  • line 4, column 65: Relative href value on self link: /atom.xml [help]
<link type="application/atom+xml" href="/atom.xml" rel="self"/>
                                                                ^

_______________________________________________
swift-users mailing list
swift-users@swift.org
https://lists.swift.org/mailman/listinfo/swift-users

_______________________________________________
swift-users mailing list
swift-users@swift.org
https://lists.swift.org/mailman/listinfo/swift-users


(Neil Tiffin) #5

Ted,

Working like a champ.

Thanks,

Neil

···

On Mar 25, 2016, at 3:03 PM, Ted Kremenek <kremenek@apple.com> wrote:

Can you try now?

On Mar 25, 2016, at 5:01 AM, Neil <neil@fairwindsoft.com <mailto:neil@fairwindsoft.com>> wrote:

Thanks, Ted,

Unfortunately, it still does not load in Vienna (http://www.vienna-rss.org <http://www.vienna-rss.org/>).

Neil

On Mar 24, 2016, at 12:18 PM, Ted Kremenek <kremenek@apple.com <mailto:kremenek@apple.com>> wrote:

Hi Neil,

Aside from the encoding issue (which we are looking into), this should now be fixed. Can you check on your end?

Thanks,
Ted

On Mar 22, 2016, at 5:53 AM, Neil via swift-users <swift-users@swift.org <mailto:swift-users@swift.org>> wrote:

Hello all,

What is the correct place to report that swift.org <http://swift.org/> rss feeds are broken? The feed does not work with Vienna on OS X and fails W3C validation.

Thanks,

Neil

https://validator.w3.org/feed/check.cgi?url=feed%3Ahttps%3A%2F%2Fswift.org%2Fatom.xml <https://validator.w3.org/feed/check.cgi?url=feed%3Ahttps%3A%2F%2Fswift.org%2Fatom.xml>
————————————————————————————————————————————
Sorry

This feed does not validate.
  • line 15, column 21: id must be a full and valid URL: /blog/welcome (9 occurrences) [help]
   <id>/blog/welcome</id>
                    ^
  • line 54, column 2: Missing entry element: author (9 occurrences) [help]
</entry>
^
In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
  • Your feed appears to be encoded as "utf-8", but your server is reporting "US-ASCII" [help]

  • line 4, column 65: Relative href value on self link: /atom.xml [help]
<link type="application/atom+xml" href="/atom.xml" rel="self"/>
                                                                ^

_______________________________________________
swift-users mailing list
swift-users@swift.org <mailto:swift-users@swift.org>
https://lists.swift.org/mailman/listinfo/swift-users


(Ted Kremenek) #6

Great!

···

On Mar 25, 2016, at 4:19 PM, Neil <neil@fairwindsoft.com> wrote:

Ted,

Working like a champ.

Thanks,

Neil

On Mar 25, 2016, at 3:03 PM, Ted Kremenek <kremenek@apple.com> wrote:

Can you try now?

On Mar 25, 2016, at 5:01 AM, Neil <neil@fairwindsoft.com> wrote:

Thanks, Ted,

Unfortunately, it still does not load in Vienna (http://www.vienna-rss.org).

Neil

On Mar 24, 2016, at 12:18 PM, Ted Kremenek <kremenek@apple.com> wrote:

Hi Neil,

Aside from the encoding issue (which we are looking into), this should now be fixed. Can you check on your end?

Thanks,
Ted

On Mar 22, 2016, at 5:53 AM, Neil via swift-users <swift-users@swift.org> wrote:

Hello all,

What is the correct place to report that swift.org rss feeds are broken? The feed does not work with Vienna on OS X and fails W3C validation.

Thanks,

Neil

https://validator.w3.org/feed/check.cgi?url=feed%3Ahttps%3A%2F%2Fswift.org%2Fatom.xml
————————————————————————————————————————————
Sorry

This feed does not validate.
  • line 15, column 21: id must be a full and valid URL: /blog/welcome (9 occurrences) [help]
   <id>/blog/welcome</id>
                    ^
  • line 54, column 2: Missing entry element: author (9 occurrences) [help]
</entry>
^
In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
  • Your feed appears to be encoded as "utf-8", but your server is reporting "US-ASCII" [help]

  • line 4, column 65: Relative href value on self link: /atom.xml [help]
<link type="application/atom+xml" href="/atom.xml" rel="self"/>
                                                                ^

_______________________________________________
swift-users mailing list
swift-users@swift.org
https://lists.swift.org/mailman/listinfo/swift-users