Swift on Ubuntu

I am trying to build a simple swift project on ubuntu and just starting to learn swift. I get the following error when I run swift build.

     error while loading shared libraries: 
    libicuuc.so.57: cannot open shared object file: No such file or directory

Hence I tried to install libicuuc package by following commands.

    wget http://ftp.us.debian.org/debian/pool/main/i/icu/icu-devtools-dbg_57.1-6+deb9u1_amd64.deb

which works fine, then I did

    sudo dpkg -i icu-devtools-dbg_57.1-6+deb9u1_amd64.deb

I get the following error after above command

    Selecting previously unselected package icu-devtools-dbg.
    (Reading database ... 282927 files and directories currently installed.)
    Preparing to unpack icu-devtools-dbg_57.1-6+deb9u1_amd64.deb ...
    Unpacking icu-devtools-dbg (57.1-6+deb9u1) ...
    dpkg: dependency problems prevent configuration of icu-devtools-dbg:
     icu-devtools-dbg depends on libicu57 (= 57.1-6+deb9u1); however:
      Package libicu57 is not installed.
    dpkg: error processing package icu-devtools-dbg (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:

So I tried following command.

    sudo apt-get install libicu57

Which throws me following error.

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package libicu57 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package 'libicu57' has no installation candidate

And now I am stuck

You are probably using a Swift toolchain compiled for another Ubuntu version (each Ubuntu release has different libicu versions).