[Swift CI] Build Failure: OSS - Swift Package - Ubuntu 18.04 (swift 5.1) #308

Report

[FAILURE] oss-swift-5.1-package-linux-ubuntu-18_04 [#308]

Build URL:
https://ci.swift.org/job/oss-swift-5.1-package-linux-ubuntu-18_04/308/
Project:
oss-swift-5.1-package-linux-ubuntu-18_04
Date of build:
Thu, 13 Jun 2019 19:29:45 -0500
Build duration:
1 hr 13 min

Identified problems:

  • Compile Error: This build failed because of a compile error. Below is a list of all errors in the build log:

Changes

  • Commit 496b8051879232e6340c24f2e2cb8e70e0620e57 by spestov:
    AST: Fix type reconstruction for @convention(c) function types

    • edit: lib/AST/ASTDemangler.cpp
    • edit: test/TypeDecoder/structural_types.swift
  • Commit d57e86e8803f1523b41a396b9509ed122d483c11 by aarond:
    shims: use the precise Windows time functions

    • edit: src/CMakeLists.txt
    • edit: src/shims/generic_win_stubs.c
    • edit: src/shims/time.h
    • edit: src/shims/generic_win_stubs.h
  • Commit 0fee46de060ac5e1cbb66c2bc1ec92d89a03ae79 by compnerd:
    Revert "Revert "Remove libbsd dependency for Linux""

    • edit: tests/CMakeLists.txt
    • edit: src/CMakeLists.txt
    • edit: CMakeLists.txt
    • edit: src/internal.h
    • edit: src/shims.h
  • Commit 7861eba974bf59d100b579e2088fc995ab5691ed by nhawes:
    [SourceKitStressTester] Use exact version for swift-package-manager

    • edit: SourceKitStressTester/Package.swift
  • Commit 24c5dd1c52bcb9365db12412c74efaa13506664d by nhawes:
    [SwiftEvolve] Use exact version for swift-package-manager dependency

    • edit: SwiftEvolve/Package.swift
  • Commit 90d2115bac54ca0e2900f9468df8c49109a20461 by ankit_aggarwal:
    Add SWIFTPM_MODULECACHE_OVERRIDE for Swift CI

    • edit: Sources/PackageLoading/ManifestLoader.swift