[Swift CI] Build Failure: 2. Swift Source Compatibility Suite (swift 5.0) #90

Report

[FAILURE] swift-5.0-source-compat-suite [#90]

Build URL:
https://ci.swift.org/job/swift-5.0-source-compat-suite/90/
Project:
swift-5.0-source-compat-suite
Date of build:
Thu, 29 Nov 2018 12:25:14 -0600
Build duration:
3 hr 40 min

Changes

  • Commit 6d070c0387ae24ab3f20cb29bb31b24bb336f2d7 by futurejones:
    change default linker to gold for AArch64

    • edit: lib/Driver/UnixToolChains.cpp

Hi Mishal,

What is the workflow to update these UPASS’ing projects but only for 5.0 branch?

Best Regards, Pavel.

Hi Pavel,

To update the project just for swift-5.0-branch by removing the “swift-5.0-branch: line.

"xfail": {
"compatibility": {
"4.2": {
"branch": {
"master": "https://bugs.swift.org/browse/SR-8250",
"swift-5.0-branch": "https://bugs.swift.org/browse/SR-8250"
}
}
}
}
Thanks,

Mishal Shah

Thanks! I’m on it then.

would triggering @swift-ci please test in swift-compat-suite test such changes?

Created PR https://github.com/apple/swift-source-compat-suite/pull/294 to Un-XFAIL both Kitura and NetService on master and 5.0

Terms of Service

Privacy Policy

Cookie Policy