Swift 2.3 branch build broken


(Matt Rajca) #1

Hello,

I’ve been unable to build Swift 2.3 with both Xcode 8 GM on 10.12 and Xcode 7.3/8 GM on 10.11.

Trying to build with Xcode 8 GM on 10.12 and 7.3 GM on 10.11 results in: "error: protocol '__BridgedNSError' requires '_NSErrorDomain' to be available on OS X 10.9.0 and newer” errors.
Building with Xcode 8 on 10.11 results in errors in the CoreData overlay (namely NSFetchRequestResult protocol declarations being missing).

What’s the supported configuration for building the Swift 2.3 branch and will there be an updated 2.3 GM release tagged?

— Matt


(Devin Coughlin) #2

Hello,

I’ve been unable to build Swift 2.3 with both Xcode 8 GM on 10.12 and Xcode 7.3/8 GM on 10.11.

Trying to build with Xcode 8 GM on 10.12 and 7.3 GM on 10.11 results in: "error: protocol '__BridgedNSError' requires '_NSErrorDomain' to be available on OS X 10.9.0 and newer” errors.

This symptom sounds like you are using the swift-2.3-branch branch of swift-clang. You actually need to use the *swift-3.0-branch* branch for both swift-clang and swift-llvm even when building the swift-2.3-branch of swift.

Devin

···

On Sep 9, 2016, at 11:50 AM, Matt Rajca via swift-dev <swift-dev@swift.org> wrote:

Building with Xcode 8 on 10.11 results in errors in the CoreData overlay (namely NSFetchRequestResult protocol declarations being missing).

What’s the supported configuration for building the Swift 2.3 branch and will there be an updated 2.3 GM release tagged?

— Matt

_______________________________________________
swift-dev mailing list
swift-dev@swift.org
https://lists.swift.org/mailman/listinfo/swift-dev


(Ben Langmuir) #3

+Nicole, Ted

Can we delete swift-2.3-branch in swift-clang/swift-llvm? This is a common gotcha when checking out 2.3. If it’s not already tagged (which would be surprising), we can tag this for archival.

Ben

···

On Sep 9, 2016, at 1:39 PM, Devin Coughlin via swift-dev <swift-dev@swift.org> wrote:

On Sep 9, 2016, at 11:50 AM, Matt Rajca via swift-dev <swift-dev@swift.org> wrote:

Hello,

I’ve been unable to build Swift 2.3 with both Xcode 8 GM on 10.12 and Xcode 7.3/8 GM on 10.11.

Trying to build with Xcode 8 GM on 10.12 and 7.3 GM on 10.11 results in: "error: protocol '__BridgedNSError' requires '_NSErrorDomain' to be available on OS X 10.9.0 and newer” errors.

This symptom sounds like you are using the swift-2.3-branch branch of swift-clang. You actually need to use the *swift-3.0-branch* branch for both swift-clang and swift-llvm even when building the swift-2.3-branch of swift.

Devin

Building with Xcode 8 on 10.11 results in errors in the CoreData overlay (namely NSFetchRequestResult protocol declarations being missing).

What’s the supported configuration for building the Swift 2.3 branch and will there be an updated 2.3 GM release tagged?

— Matt

_______________________________________________
swift-dev mailing list
swift-dev@swift.org
https://lists.swift.org/mailman/listinfo/swift-dev

_______________________________________________
swift-dev mailing list
swift-dev@swift.org
https://lists.swift.org/mailman/listinfo/swift-dev


(Jon Rafkind) #4

Is there a plan to make a swift-2.3-RELEASE tag for the various swift-* repos? I am also interested in creating a working swift-2.3 from source. What branches should I use? So far I've tried this configuration, without success

swift: swift-2.3-branch

llvm: swift-3.0-branch

clang: swift-3.0-branch

compiler-rt: swift-3.0-branch

cmark: swift-2.3-branch

lldb: swift-2.3-branch

I think the other swift directories checked out by update-checkout --clone, such as swift-corelibs-foundation, are not applicable for swift-2.3.

···

On 09/09/2016 01:58 PM, Ben Langmuir via swift-dev wrote:

+Nicole, Ted

Can we delete swift-2.3-branch in swift-clang/swift-llvm? This is a common gotcha when checking out 2.3. If it’s not already tagged (which would be surprising), we can tag this for archival.

Ben

On Sep 9, 2016, at 1:39 PM, Devin Coughlin via swift-dev <swift-dev@swift.org> wrote:

On Sep 9, 2016, at 11:50 AM, Matt Rajca via swift-dev <swift-dev@swift.org> wrote:

Hello,

I’ve been unable to build Swift 2.3 with both Xcode 8 GM on 10.12 and Xcode 7.3/8 GM on 10.11.

Trying to build with Xcode 8 GM on 10.12 and 7.3 GM on 10.11 results in: "error: protocol '__BridgedNSError' requires '_NSErrorDomain' to be available on OS X 10.9.0 and newer” errors.

This symptom sounds like you are using the swift-2.3-branch branch of swift-clang. You actually need to use the *swift-3.0-branch* branch for both swift-clang and swift-llvm even when building the swift-2.3-branch of swift.

Devin

Building with Xcode 8 on 10.11 results in errors in the CoreData overlay (namely NSFetchRequestResult protocol declarations being missing).

What’s the supported configuration for building the Swift 2.3 branch and will there be an updated 2.3 GM release tagged?

— Matt

_______________________________________________
swift-dev mailing list
swift-dev@swift.org
https://lists.swift.org/mailman/listinfo/swift-dev

_______________________________________________
swift-dev mailing list
swift-dev@swift.org
https://lists.swift.org/mailman/listinfo/swift-dev

_______________________________________________
swift-dev mailing list
swift-dev@swift.org
https://lists.swift.org/mailman/listinfo/swift-dev