Posting this here since it is probably redundant, but I don't know how to word it to find it:
When a type is specified in a generic function like
let foo = myPointer.load(as: UInt16.self) the
UInt16.self is required to make it a thing* the compiler can handle. However, from a developers perspective, it would be much more readable and intuitive to just write
let foo = myPointer.load(as: UInt16) and have the compiler figure out the rest.
Is this a super bad idea, and compilers can't work like this? Or is this something that's being proposed or discussed? Where would I find this? What are the words/concepts I'm missing?