SE-0366: Move Function + "Use After Move" Diagnostic

Seems to me that we should not commit to naming until we have more of the borrowing story fleshed out. I wonder if we could introduce _move as a placeholder knowing that this will change in future versions. Sort of reminds me of _modify/yield which folks can use but not fully supported.