It would be very nice if the core team would define what @uncheck vs checked (example CheckedContinuation ) will mean in Swift. Similarly how it is defined that Unsafe in Swift relates only to memory safety.
Presumably the @unchecked Sendable type will be “checked” for ownership violations?
I’d like to suggest @forced Sendable as an alternative spelling. Reminds me of git force push.
Maybe even @coerced Sendable.