To add on to this, a search for "swift builder" on Google turns up lots of articles about using the builder design pattern in Swift. Choosing the @builder
name would, in the best case, hide these otherwise relevant results. In the worst case, it would make searching for information about the @builder
attribute quite difficult. OTOH, searching for "swift result builder" or "swift return value builder" already returns results that almost exclusively discuss "function builders." I don't get the sense that choosing either of these names would 'step on the toes' of existing concepts.
An interesting middle ground is searching for "swift value builder", which returns results which (at least for myself) are approximately 50/50 split between "function builders" and "builder design pattern." I worry that this is the realm we would end up in if we chose a name like @builder
.
FWIW, I support the @resultBuilder
or @returnValueBuilder
namings over the alternatives in this thread (including @functionBuilder
) with no strong preference between the two.