I followed the pitch and quickly read the proposal.
+1 on adding
Half as a typealias.
and for consistency
Double should be reversed and be the aliases for
+1, I've been looking forward to this for a while. I will be using this indirectly to support canonicalization of float point numbers in a CBOR library.