* What is your evaluation of the proposal?
I am strongly opposed to this proposal.
* Is the problem being addressed significant enough to warrant a change to
No. This can easily be addressed with a style-guide by programmers/teams
who think it's a significant problem. A lot of us have not encountered an
issue with the current behaviour. We end up with more concise code because
of it. Those who are worried about this behaviour can follow a practice of
adding `self.` in front of all their instance members. This is no different
from having confusingly named functions or variables.
* Does this proposal fit well with the feel and direction of Swift?
Yes in the sense that it errs on the side of greater safety. But leaning
too much in that direction can lead to unnecessary changes with very small
upsides. I don't think the problem is big enough to warrant a language
* If you have you used other languages or libraries with a similar feature,
how do you feel that this proposal compares to those?
I have not, but I have enjoyed having `self.` be optional in the Swift code
I've written so far.
* How much effort did you put into your review? A glance, a quick reading,
or an in-depth study?
I have quickly reviewed the arguments on the two sides by going through the